• Addtional Tags跟自动刷新插件有冲突??
    dust2k  •  4个月前  •  141次点击

    发现redmine_refresh这个插件有用途,准备安装,但是在bundle install的时候报这个错误,对Ruby,Gem不熟悉,能不能指点一下?

     

    Fetching gem metadata from https://rubygems.org/.........
    Resolving dependencies...
    Could not find compatible versions

    Because every version of additional_tags depends on redmine_plugin_kit >= 0
     and redmine_plugin_kit >= 1.0.3 depends on deface = 1.9.0,
     every version of additional_tags requires deface = 1.9.0 or redmine_plugin_kit >= 0, < 1.0.3.
    Because redmine_plugin_kit >= 1.0.2, < 1.0.3 depends on deface = 1.8.2
     and redmine_plugin_kit < 1.0.2 depends on deface = 1.8.1,
     redmine_plugin_kit < 1.0.3 requires deface = 1.8.1 OR = 1.8.2.
    Thus, every version of additional_tags requires deface = 1.8.1 OR = 1.8.2 OR = 1.9.0.
    So, because Gemfile depends on additional_tags >= 0
     and Gemfile depends on deface = 1.6.2,
     version solving has failed.

  • dust2k 4个月前
    #1

    晕,这个版本问题不是因为refresh这个插件,估计是之前安装的插件的问题。。。

  • dust2k 4个月前
    #2

    搞定了,redmine_base_deface的插件里的Gem文件定义了1.62,主要避免和redmine 4.2版本的冲突,comment out就可以了。。

  • dust2k 4个月前
    #3

    这个redmine_refresh的插件里带了一个redmine_base_deface的插件,redmine_base_deface目录里有个文件PluginGemfile导致了不兼容,可以删掉这个文件,或者把里面的那行comment掉

     

  • Redminecn Admin 4个月前
    #4
    dust2k #3 回复

    嗯嗯,也可以统一两个插件依赖的gem版本,将 redmine_base_deface 的 PluginGemfile 中的 deface 升级到 1.9.0版本。

  • 为 Redmine 爱好者打造的知识社区,其中包含 Redmine 插件资源、使用交流、二次开发、插件安装、配置优化等
    已注册用户请 登录
  • 参与人
© 2023 Redminecn.com 版权所有

辽ICP备18016669号-2

粤公网安备 44030602007921号