• 问题详情页面,说明项目下添加的图片,正常显示,使用PDF导出后,PDF文件页面空白无图片显示
    hegenshuo  •  20天前  •  228次点击

     

    bitnami redmine 版本5.0.3版本

  • Redminecn Admin 28天前
    #1

    管理员登录 -》后台 -〉信息里看下ImageMagick PDF 支持 (可选) 是否是有效的?

  • hegenshuo 28天前
    #2

    是有点问题 但是我不知道如何修复

  • hegenshuo 28天前
    #3

    插件更新页面也是提示无法更新,单独cmd ping www.redmine.org 是能返回信息的。

  • Redminecn Admin 28天前
    #4
    hegenshuo #2 回复

    这个需要额外安装 GhostScript (https://ghostscript.com/)

  • hegenshuo 28天前
    #5

    好的 谢谢了 ,我琢磨一下子。

  • Redminecn Admin 28天前
    #6
    hegenshuo #5 回复

    那个 watermark 插件有更新,修复了一些显示问题,有时间可以更新下😄

  • hegenshuo 28天前
    #7

    谢谢了 答主 。😁

  • hegenshuo 28天前
    #8

    导出后还是无法显示图片。这个版本是5.0.3  我记得我5.0.0版本是没有问题的。

  • Redminecn Admin 28天前
    #9
    hegenshuo #8 回复
    1. 参考下这个看看是否配置好
      https://www.redmine.org/boards/2/topics/62579?r=64970
    2. 可能是图片的问题?
  • hegenshuo 22天前
    #10

    PDF 导出时,我发现插在 问题描述中的图片,导出后pdf文件可以看见,在编辑说明中的图片无法显示;

    是否需要配置thumbnail.rb 文件中的内容?

  • hegenshuo 22天前
    #11

  • Redminecn Admin 21天前
    #12
    hegenshuo #11 回复


    看起来 5.0.3 和 5.1 版本只差了这个格式,我这边在linux上测试PDF里是可以正常显示编辑说明里的图片的

  • hegenshuo 21天前
    #13

    修改了,目前发现,网页上的图片,右键复制图片,粘贴进来后,PDF导出可以正常显示,本地和剪贴板剪贴进来的都无法正常显示。

  • hegenshuo 21天前
    #14

    修改之前也是这样

     

  • Redminecn Admin 21天前
    #15
    hegenshuo #13 回复

    我在linux上测试是用的本地剪切板截图,是正常的

  • hegenshuo 21天前
    #16

    您好,帮我看看这里需要配置嘛?

     

  • Redminecn Admin 21天前
    #17
    hegenshuo #16 回复

    要配置的

  • hegenshuo 21天前
    #18

    配置完 重启所有服务还是  一样,那就算了吧 。谢谢了。

  • Redminecn Admin 20天前
    #19
    hegenshuo #18 回复

    还有就是上传图片的url或权限问题,导致的无法在PDF中显示

  • 为 Redmine 爱好者打造的知识社区,其中包含 Redmine 插件资源、使用交流、二次开发、插件安装、配置优化等
    已注册用户请 登录
  • 参与人
© 2023 Redminecn.com 版权所有

辽ICP备18016669号-2

粤公网安备 44030602007921号