• 添加插件时报错
    水果六  •  17天前  •  94次点击

    站长好:

             我在添加dmsf插件时,提示如下错误。请问应该如何处理?万分感谢!

    [root@vnc plugins]# RAILS_ENV=production bundle exec rake redmine:plugins:migrate
    (in /application/nginx/html/redmine-5.0.8)
    rake aborted!
    Redmine::PluginNotFound: Plugin not found. The directory for plugin redmine_dmsf should be /application/nginx/html/redmine-5.0.8/plugins/redmine_dmsf.
    /application/nginx/html/redmine-5.0.8/lib/redmine/plugin.rb:104:in `register'
    /application/nginx/html/redmine-5.0.8/plugins/redmine_dmsf-3.1.3/init.rb:23:in `<top (required)>'
    /application/nginx/html/redmine-5.0.8/lib/redmine/plugin_loader.rb:31:in `load'
    /application/nginx/html/redmine-5.0.8/lib/redmine/plugin_loader.rb:31:in `run_initializer'
    /application/nginx/html/redmine-5.0.8/lib/redmine/plugin_loader.rb:108:in `each'
    /application/nginx/html/redmine-5.0.8/lib/redmine/plugin_loader.rb:108:in `block in load'
    /usr/local/rvm/gems/ruby-2.7.0/gems/activesupport-6.1.7.7/lib/active_support/callbacks.rb:427:in `instance_exec'
    /usr/local/rvm/gems/ruby-2.7.0/gems/activesupport-6.1.7.7/lib/active_support/callbacks.rb:427:in `block in make_lambda'
    /usr/local/rvm/gems/ruby-2.7.0/gems/activesupport-6.1.7.7/lib/active_support/callbacks.rb:198:in `block (2 levels) in halting'
    /usr/local/rvm/gems/ruby-2.7.0/gems/activesupport-6.1.7.7/lib/active_support/callbacks.rb:604:in `block (2 levels) in default_terminator'
    /usr/local/rvm/gems/ruby-2.7.0/gems/activesupport-6.1.7.7/lib/active_support/callbacks.rb:603:in `catch'
    /usr/local/rvm/gems/ruby-2.7.0/gems/activesupport-6.1.7.7/lib/active_support/callbacks.rb:603:in `block in default_terminator'
    /usr/local/rvm/gems/ruby-2.7.0/gems/activesupport-6.1.7.7/lib/active_support/callbacks.rb:199:in `block in halting'
    /usr/local/rvm/gems/ruby-2.7.0/gems/activesupport-6.1.7.7/lib/active_support/callbacks.rb:512:in `block in invoke_before'
    /usr/local/rvm/gems/ruby-2.7.0/gems/activesupport-6.1.7.7/lib/active_support/callbacks.rb:512:in `each'
    /usr/local/rvm/gems/ruby-2.7.0/gems/activesupport-6.1.7.7/lib/active_support/callbacks.rb:512:in `invoke_before'
    /usr/local/rvm/gems/ruby-2.7.0/gems/activesupport-6.1.7.7/lib/active_support/callbacks.rb:105:in `run_callbacks'
    /usr/local/rvm/gems/ruby-2.7.0/gems/activesupport-6.1.7.7/lib/active_support/reloader.rb:88:in `prepare!'
    /usr/local/rvm/gems/ruby-2.7.0/gems/railties-6.1.7.7/lib/rails/application/finisher.rb:124:in `block in <module:Finisher>'
    /usr/local/rvm/gems/ruby-2.7.0/gems/railties-6.1.7.7/lib/rails/initializable.rb:32:in `instance_exec'
    /usr/local/rvm/gems/ruby-2.7.0/gems/railties-6.1.7.7/lib/rails/initializable.rb:32:in `run'
    /usr/local/rvm/gems/ruby-2.7.0/gems/railties-6.1.7.7/lib/rails/initializable.rb:61:in `block in run_initializers'
    /usr/local/rvm/gems/ruby-2.7.0/gems/railties-6.1.7.7/lib/rails/initializable.rb:60:in `run_initializers'
    /usr/local/rvm/gems/ruby-2.7.0/gems/railties-6.1.7.7/lib/rails/application.rb:391:in `initialize!'
    /application/nginx/html/redmine-5.0.8/config/environment.rb:16:in `<top (required)>'
    /usr/local/rvm/gems/ruby-2.7.0/gems/zeitwerk-2.6.13/lib/zeitwerk/kernel.rb:34:in `require'
    /usr/local/rvm/gems/ruby-2.7.0/gems/zeitwerk-2.6.13/lib/zeitwerk/kernel.rb:34:in `require'
    /usr/local/rvm/gems/ruby-2.7.0/gems/activesupport-6.1.7.7/lib/active_support/dependencies.rb:332:in `block in require'
    /usr/local/rvm/gems/ruby-2.7.0/gems/activesupport-6.1.7.7/lib/active_support/dependencies.rb:299:in `load_dependency'
    /usr/local/rvm/gems/ruby-2.7.0/gems/activesupport-6.1.7.7/lib/active_support/dependencies.rb:332:in `require'
    /usr/local/rvm/gems/ruby-2.7.0/gems/railties-6.1.7.7/lib/rails/application.rb:367:in `require_environment!'
    /usr/local/rvm/gems/ruby-2.7.0/gems/railties-6.1.7.7/lib/rails/application.rb:533:in `block in run_tasks_blocks'
    /usr/local/rvm/gems/ruby-2.7.0/gems/rake-13.2.1/exe/rake:27:in `<top (required)>'
    /usr/local/rvm/gems/ruby-2.7.0/bin/ruby_executable_hooks:22:in `eval'
    /usr/local/rvm/gems/ruby-2.7.0/bin/ruby_executable_hooks:22:in `<main>'
    Tasks: TOP => redmine:plugins:migrate => environment
    (See full trace by running task with --trace)
    
    
  • 水果六 18天前
    #1

    我的插件文件如上

  • Redminecn Admin 18天前
    #2


    文件夹名字去掉版本号

  • 水果六 17天前
    #3

    感谢站长的回复,插件安装上后,怎么在线编辑文档和给权限呢?

  • Redminecn Admin 17天前
    #4
    水果六 #3 回复

    行内显示和编辑文档需要安装 libreoffice
    权限是在管理 → 角色和权限中配置
    具体的使用说明详见:
    https://github.com/danmunn/redmine_dmsf

  • 水果六 17天前
    #5

    好的,再次感谢!

  • Redminecn Admin 17天前
    #6
    水果六 #5 回复

    客气啦

  • 为 Redmine 爱好者打造的知识社区,其中包含 Redmine 插件资源、使用交流、二次开发、插件安装、配置优化等
    已注册用户请 登录
  • 参与人
© 2023 Redminecn.com 版权所有

辽ICP备18016669号-2

粤公网安备 44030602007921号